Dockerized SugarCRM loads properly after install Wizard, but not after saving changed files and rebuilding

I am trying to use Docker for local development of a SugarCRM 11 application. I can complete the wizard successfully, and the SugarCRM login screen appears after completing the wizard.

However, if I copy the files generated and modified by the Install Wizard from the container to my local machine, then try building the container, I see a screen that just says Loading...

The files I'm copying are from /var/www/html, which is where all of my SugarCRM files and directories are located.

As part of the Dockerfile, I am granting all permissions as described here:  https://support.sugarcrm.com/Knowledge_Base/Platform_Management/Required_File_System_Permissions_on_Linux/

I know that other people have used Docker to build and deploy SugarCRM (I've read the blog posts in Sugarclub), but I have not seen documentation for configuring manually (i.e. not using the install wizard) or for seeing an error like this one.


I have tried reviewing phpinfo() and didn't notice anything. I also have inspected the browser console, but the only errors I see in the perpetual Loading... state are also seen when I complete the wizard and successfully reach the login page. In other words:  there is no helpful information in the browser console.

Any help is appreciated, thanks!

Sources consulted: 

http://cheleguanaco.blogspot.com/2016/05/sugarcrm-troubleshooting-still-loading.html

https://sugarclub.sugarcrm.com/dev-club/f/questions-answers/544/loading-displaying-on-screen-nothing-display-after-that-not-even-login-screen

  • I use sugardockerizer, and i have a very favorable user experience.

  • A few suggestions:

    Check your disk space:

    I sometimes see the persistent Loading in my development environment when I run out of disk space, as you log in it is trying to write to cache but can't.

    Check your file permissions:

    Make sure your files and directories have the right permissions, I use the following three commands from sugar root as my "fix-it":

    sudo chown -R  apache:apache *

    sudo find . -type d -exec chmod 775 {} \;

    sudo find . -type f -exec chmod 664 {} \;

    These respectively give all ownership and groups as apache, sets all directories to 775 and all files to 664.

    I then do another QRR to rebuild any cache files that may have had problems updating/writing.

    See if that helps, good luck.

    FrancescaS

  • Check the .htaccess file. If it is in the root of your docker apache and if it is correct. Can you check in developer tools when opening sugar to see what is going on there? It looks to me like the index.php can't reach the api endpoints due to the lack of the htaccess file