Can't open documents after upgrading 11.0.3 > 12.0.0

I completed the upgrade from 11.0.3 > 12.0.0 via Silent Upgrade. Everything seems fine in Sugar instance, except I cannot open any documents that were added to Sugar prior to the upgrade:

I checked inside my ./upload directory, and it looks like Sugar has moved all of the old upload files into a new subdirectory (also called upload) during the upgrade process. So all the old files are now in ./upload/upload.

I tried resetting ownership/permissions on the entire ./upload directory, ran QRR, rebuild relationships, cleared /cache, changed the /upload/ filepath in config.php to /upload/upload/, removed the extra /upload subdirectory, but nothing worked.

Seems like the default /upload directory structure was changed with this update, but how do I get my old uploads to be mapped properly so we can access them in Sugar?

Thank you.

  • Hi ,

    We did indeed updated updated the way upload directory works in 11.1 as you can see in our customization guide, however, that is only relevant for MLP (Module Loadable Packages), no updates have been made to other files.

    I double checked our codebase on v12 and I couldn't identify any changes that would force "/upload/upload" nor move uploaded files to the new structure.

    I'm assuming you're in a on-premise install, could you give us more details on your structure and config? (ls -lrt on your file system and config details)..


    SugarCRM | Principal Developer Advocate