Sugar Instance: Procedure Instance does not get executed

Hi All,

I was trying example given in Your First Integration in 60 Minutes | Sugar Integrate  .

I was trying to syn data between "Salesforce Sales" and "Sugar Enterprise". For this i followed below steps

1. Created trial version account on and Sugar Free Trial | SugarCRM  

2. Tried adapters Authentication i.e. "Salesforce Sales" and "Sugar Enterprise" and tested few API Docs. For both it worked properly. For both Accounts api (Try out) worked properly

3. Created new procedure and imported JSON data provided in the documentation. 

4. Created new procedure Instance and added destination and source instance i.e. destination from SugarCRM and Source as Salesforce Sales.  Added email for notification and Webhook as blank.

5. Skipped Common Resource set up

6. When i click execute link of procedure instance data is not getting syn between Salesforce and SugarCRM. I had created new contact in salesforce and expecting that to appear in SugarCRM

7. Checked different Logs but did not find that Procedure Instance got executed. Do not not reason why it did not get executed. I did not get any error email (which i setup in create procedure Instance page).

I am attaching my screen shot to here in order to clear understanding on my queries.



Matt Marum  Dev Club 

  • Tried to execute procedure in debugging mode. 

    1. Clicked on select Instance and selected Procedure Instance

    2. Clicked on Select Trigger, as i do not have any event so i did not choose any thing

    3. Clicked on run then it showed error saying "Failed to simulate Formula Instance" (Attached the error)Error

    4. procedures

  • there is a way to turn on logging for a procedure in debug mode. This will give you more verbose information about each step. But, you must make this setting PER PROCEDURE.

    1. Grab the procedure id. Either from the URL when editing or from the procedures screen
    2. Click on API DOCS in top right corner of the Sugar integrate Application – not api docs for any particular adapter or instance. These re the docs for Sugar Integrate
    3. Click on Procedures on the left-side sub-menu
    4. Look for PATCH /formulas/{id}
    5. Click TRY IT OUT
    6. Enter in the procedure ID
    7. Enter {"debugLoggingEnabled": true} as the body
    8. Execute

    Now you will see information about each step of your procedure in the debugger. You can also use console.log and those will show in the debugger now as well. Note the console.log can only take one parameter to log out.

    Hopefully this may help you troubleshoot your procedure.