Non-blob field type is changed to blob field type error during SugarCRM Pro 7.7.2.0 to 7.7.2.2

Good Day!

I'd like to ask the community if anyone knows how to solve the problem below. I cannot proceed with my current version upgrade due to this error.

My Vardefs:

$dictionary['Contact']['fields']['lead_source'] = array(
    'required' => false,
    'name' => 'lead_source',
    'vname' => 'LBL_LEAD_SOURCE',
    'type' => 'multienum',
    'massupdate' => true,
    'no_default' => false,
    'comments' => '',
    'help' => '',
    'importable' => 'true',
    'duplicate_merge' => 'enabled',
    'duplicate_merge_dom_value' => '1',
    'audited' => false,
    'reportable' => true,
    'unified_search' => false,
    'merge_filter' => 'disabled',
    'calculated' => false,
    'size' => '20',
    'options' => 'contact_lead_source',
    'studio' => 'visible',
    'dependency' => '',
    'isMultiSelect' => true,
);

I`ve been looking for the solution to this, but I couldn`t find any on the internet or even here in our community.

Parents
  • Hi

    You can check some information about "Health Check Error: Type change" on the link below: 

    https://support.sugarcrm.com/Knowledge_Base/Installation_Upgrade/Troubleshooting_Health_Check_Output/Health_Check_Error_Type_Change/

    Let me know if this helps or if you have any further doubts or questions. 

    André

  • Hi , I was able to resolve this issue. But I have a new issue right now. Pre-upgrade failed due to a "custom configuration has been detected which is incompatible with the upgrade process" error.

    Tue, 24 Jan 2023 03:24:32 +0000 [Upgrader] - Finished script BackupFiles
    Tue, 24 Jan 2023 03:24:32 +0000 [Upgrader] - Starting script CheckAllowOverride
    Tue, 24 Jan 2023 03:24:34 +0000 [Upgrader] - Finished script CheckAllowOverride
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Starting script CheckFTSConfig
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Finished script CheckFTSConfig
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Starting script CheckComposerConfig
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Using /var/www/html/PMS/composer.json as composer.json source
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Using /var/www/html/PMS/composer.lock as composer.lock source
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Using cache/upgrades/temp/SugarPro-Upgrade-7.7.x-to-7.7.2.2/composer.json as composer.json target
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - No hash available in lock file
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Custom composer configuration detected
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Found valid package psr/log with version constraint 1.0.0
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Found valid package ruflin/elastica with version constraint v1.4.3.0
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Found valid package onelogin/php-saml with version constraint 2.10.5
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Found valid package aws/aws-sdk-php with version constraint 2.7.7
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Found valid package phpmailer/phpmailer with version constraint v5.2.22
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Found valid package ircmaxell/password-compat with version constraint v1.0.4
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Found valid package symfony/security-core with version constraint v2.7.1
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Found valid package symfony/security-csrf with version constraint v2.7.1
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Found valid package symfony/validator with version constraint v2.7.1
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Found valid package symfony/translation with version constraint v2.7.1
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Found valid package symfony/console with version constraint v2.7.1
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Found valid package google/apiclient with version constraint 1.1.4
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Found valid package parsecsv/php-parsecsv with version constraint 0.4.5
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Found valid package paragonie/random_compat with version constraint v2.0.2
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Found valid package ramsey/uuid with version constraint 2.9.0
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Found valid package moontoast/math with version constraint 1.1.0
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Skipping platform package php
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Found valid repository https://github.com/sugarcrm/Elastica with type git
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Repository https://github.com/sugarcrm/php-saml.git of type git is missing
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Generating proposal file cache/upgrades/temp/SugarPro-Upgrade-7.7.x-to-7.7.2.2/composer.json.proposal
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Saving file cache/upgrades/temp/SugarPro-Upgrade-7.7.x-to-7.7.2.2/composer.json.proposal to disk
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - ERROR: A custom composer configuration has been detected which is incompatible with the upgrade process. Consult the SugarCRM Administration Guide for more details on how to resolve this issue. Detailed logs are available in UpgradeWizard.log.
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - Finished script CheckComposerConfig
    Tue, 24 Jan 2023 03:24:35 +0000 [Upgrader] - ERROR: Pre-upgrade stage failed!

  • Can you share what you have in UpgradeWizard.log ?

  • , That was the log above; it says "Custom composer configuration detected".

Reply Children
No Data