WAMP local sugar from backup 404

Hi.  I'm trying to set up a local version of Sugar 11 from a cloud backup.    I'm fairly confident the prerequisites/requirements have been met (https://support.sugarcrm.com/Documentation/Sugar_Versions/11.0/Ent/Installation_and_Upgrade_Guide/#Installation_Prerequisites).  

I have a clean version of Sugar 11 on localhost which seems to work, I'm using WAMP 64-bit, PHP 7.3.21 (or 7.4.9) , MySQL 5.7.31, Apache 2.4.46, Elasticsearch 7.13.2. Chrome Version 91.0.4472.124 (Official Build) (64-bit). 

I've followed the instructions from https://support.sugarcrm.com/Documentation/Sugar_Developer/Sugar_Developer_Guide_10.3/Integration/Migration/Migrating_From_Sugar_Cloud_to_On-Site/  and when I try to access the install I get the 'Loading...' box and an error in the console "Failed to load resource: the server responded with a status of 404 (Not Found) at <backupSugar>/rest/v11_12/metadata/public?type_filter=&platform=base&module_dependencies=1  

I've cleared the browser cache and the Sugar cache folder and reloaded. Does anyone have any idea how to fix this? 



  • I know you have put a lot of work into this already but if you are still at a point where its not working you might want to look into the Vagrant setup.  I did everything manually for all my developers in the past but now we all converted over to the Vagrant setup and it works great and requires almost no setup, just installing 2 programs and running a command line.  If you need help just ask.

  • Hi Kenneth.  It's getting to that point... 

    I did have a clean development 10.3 copy running on Vagrant, although found I couldn't add fields with the module builder and the quick repair was far from 'quick' which was why I started down the wamp route in the first place. 

    I've fired up vagrant again and when I go to http://localhost:8080/sugar/  the installer kicks in ('installer_locked' => false).  Do you know if its possible to run a backup on Vagrant?

  • The adding of fields in module builder APPEARS to be a bug, and a long standing one at that.  I sent in a case for it but I still don't know if its got a bug report yet.  Nothing to do with Vagrant though.

    I use a script for repairs so the speed difference isn't so great as my dev envirnment (phpstorm) kicks it off when its needed and just clears the cache if thats all thats needed.

    I have my DB on a copy of MySQL outside of Vagrant as the VM doesnt have the disk space for our DB.  If thats what you mean by backup then yes it is possible.

    I have had problems off and on installing a clean system, it works 75% of the time.   But directing it to use a copy of my production database works every time.

  • Thanks again. By "backup" I mean a copy of our cloud instance including the existing customisations rather than a fresh install. After starting Vagrant http://localhost:8080/sugar goes straight to an installer (but wont proceed with 'installer_locked' => true), if I understood correctly at this point a backup should go straight to the login screen, could you elaborate on how to achieve that please?

  • Hi James,

    You have to change the 'installer_locked' => false in the config.php file and try restoring the instance again. For more information go through this link.

    Hope this information helps.

    Thanks & Regards,

    Poojitha K


Reply Children
  • Hi Poojitha, thanks for responding.

    I've changed installer_locked to false and I then get the message :-

    "AllowOverride setup for .htaccess
    Test for .htaccess rewrites failed. This usually means you do not have AllowOverride set up for Sugar directory."

    I've added this to the apache2.conf

    <Directory "/var/www/html/sugar">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    Allow from all

    If I run "apachectl -M | grep rewrite" it returns "rewrite_module (shared)" which I believe means rewrite is enabled.

    If I add an .htaccess file as posted above I still get the same '.htaccess rewrites failed.' message.

    If I amend the .htaccess file with "RewriteBase /myWindowsSugarFolder"

    I get:-

    Writable Cache Sub-Directories The files or directories listed below are not writeable or are missing and cannot be created. Depending on your Operating System, correcting this may require you to change permissions on the files or parent directory (chmod 755), or to right click on the parent directory and uncheck the 'read only' option and apply it to all subfolders.

    Please fix the following files or directories before proceeding:

    AllowOverride setup for .htaccess
    Test for .htaccess rewrites failed. This usually means you do not have AllowOverride set up for Sugar directory.

    I seem to have basically come full circle as the .htaccess message was part of the initial reason I'd opted to try WAMP instead, as I'd got the message when I first tried set up a backup on Vagrant. 

    Any suggestion what I else can do would be helpful.

    Thanks again