AllowOverride setup for .htaccess

Im trying to setup a VM - Ubuntu 18 to run a local copy of sugar 9 enterprise to further develop custom code. I did have sugar running as a LAMP on my mac but this has caused issues and sugar advised a local VM is the better way to develop sugarcrm. We currently have a cloud instance of sugar so amusing a backup of that server to create the local system.

I first tried using vagrant as described in but get the following error when trying to install sugar

AllowOverride setup for .htaccessTest for .htaccess rewrites failed. This usually means you do not have AllowOverride set up for Sugar directory.


I know there has been discussions on this but have tried all these fixes and nothing seems to be working.

I have also tried setting up a Ubuntu server and installing my own LAMP stack but still get the same error

Mod rewrite is active 

.htaccess file is being read and process

AllowOveride All set on the directory of the host

Permissions all set

Has anyone else had this problem with getting a VM setup

  • You say you are using a backup of your production server, did you copy the .htaccess file from your production environment?

    If so, check that your RewriteBase is correct, sometimes we have different paths to Sugar root on different systems, that could be your problem.


  • Hi Francesca Shiekh 

    I checked my htaccess file and it was set to "/" I tried changing it to "/sugar/" as vagrant has sugar in a subfolder on the vhost root but this didn't help. I am wandering if the problem is with my copied install of sugar but don't think we get a fresh install of sugar 9.0 enterprise to try. I checked my downloads folder on sugar and I don't get the install files just the addons

  • The page where you get your downloads

    has a dropdown at the top that always defaults to Plugins. It always takes me a second to realize it's there and change it, see if you can find your download. If not contact Sugar Support, they can help you with that.

    I am not familiar with Vagrant but the RewriteBase is relative to your website root (not your system root) so, for example, my sugar is in : /var/www/html/sugarcrm

    so the RewriteBase is:  /sugarcrm

    Maybe try removing your trailing /  and change from /sugar/ to /sugar ?

  • Thanks for all your help Francesca Shiekh, it turned out to be a bad backup file in the end. I used a fresh install of sugar ent 9 and had no issues so asked sugar to generate a new backup and that installed on the server fine. All the information and trouble shouting has at least given me a good understanding of the requirements to run sugar and now have my own ubuntu VM running sugar for local development